Results 1 to 5 of 5

Thread: Master Everdrive with nothing but a black screen - help needed!!

  1. #1
    New member fandenivoldsk's Avatar

    Join Date
    Feb 2011
    Location
    Copenhagen
    Posts
    11

    Master Everdrive with nothing but a black screen - help needed!!

    I bought a Master Everdrive over a year ago, but it is only now that I have had time to try it out on my japanese SEGA Mark III.
    I bought the Everdrive without a SD flashcart, so I use an empty 2GB SD cart that I already had and formated it to FAT16.
    Now the problem is that when I turn my SEGA Mark III on, there is no menu screen. Only a black screen and nothing else.
    If I press the A button, I am able to get 'Sonic Blast' running (I guess it was stored on the PCB somehow?), but that is the only thing I am able to do.

    I tried to copy the 'os-v5.sms' bios file and some games to the root of the cart, but without any luck getting them to show up. Should I be able to see the menu even if there is no roms on the SD cart?

    Can anyone here help me out on how to get this Master Everdrive cart to work? :-)

  2. #2
    Member Elite
    KRIKzz's Avatar

    Join Date
    Apr 2010
    Location
    Ukraine
    Posts
    1,671
    mark 3 does not work properly with oldest everdrive OS, so you should update OS somehow to use cart with mark3
    I looking for genesis 2 with motherboard VA2

  3. #3
    New member fandenivoldsk's Avatar

    Join Date
    Feb 2011
    Location
    Copenhagen
    Posts
    11
    Thanks for the reply!
    So how do I update the OS?

  4. #4
    Member Elite
    KRIKzz's Avatar

    Join Date
    Apr 2010
    Location
    Ukraine
    Posts
    1,671
    well, it is hard in case if you can't see anything on the screen (: may be use another console or send to me or try to do it in blind way
    I looking for genesis 2 with motherboard VA2

  5. #5
    Foot Soldier
    Shou's Avatar

    Join Date
    Nov 2009
    Location
    Tokyo, Japan, Asia, Earth, Solar System, Milky Way
    Posts
    460
    Is there a way to tell which OS is on the cart? I have the same exact issue.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •